Skip to content

Support the app-server daemon on Windows - #42405

Merged
copyberry[bot] merged 1 commit into
mainfrom
copyberry/codex-internal-to-codex-oss/e7fd63cf8690bcca8b5155266416f31f2f792aa2
Sep 3, 2026
Merged

copyberry[bot] merged 1 commit into
mainfrom
copyberry/codex-internal-to-codex-oss/e7fd63cf8690bcca8b5155266416f31f2f792aa2

Conversation

@copyberry

@copyberry copyberry Bot commented Sep 3, 2026 •

Copy link
Copy Markdown

Support the app-server daemon on Windows

Why

The managed app-server daemon and automatic TUI attachment were limited to
Unix, so Windows users could not share a background server across Codex
sessions.

What changed

  • Enable daemon lifecycle commands, codex agents startup, and AF_UNIX daemon
    discovery on Windows.
  • Require Windows daemons to start non-elevated and verify the discovered
    socket directory and peer before connecting.
  • Preflight detached process support, preserve path-based environment settings,
    and keep daemon processes out of the launching project's working directory.
  • Fall back to an embedded server when an implicitly discovered daemon cannot
    connect, while preserving errors for explicit remote endpoints and bypassing
    daemon reuse when CODEX_EXEC_SERVER_URL is set.

Testing

Add coverage for Windows launch restrictions and socket validation, implicit
connection fallback, executor selection, daemon discovery, and the agents
dashboard startup result.

## Why

The managed app-server daemon and automatic TUI attachment were limited to
Unix, so Windows users could not share a background server across Codex
sessions.

## What changed

- Enable daemon lifecycle commands, `codex agents` startup, and AF_UNIX daemon
  discovery on Windows.
- Require Windows daemons to start non-elevated and verify the discovered
  socket directory and peer before connecting.
- Preflight detached process support, preserve path-based environment settings,
  and keep daemon processes out of the launching project's working directory.
- Fall back to an embedded server when an implicitly discovered daemon cannot
  connect, while preserving errors for explicit remote endpoints and bypassing
  daemon reuse when `CODEX_EXEC_SERVER_URL` is set.

## Testing

Add coverage for Windows launch restrictions and socket validation, implicit
connection fallback, executor selection, daemon discovery, and the agents
dashboard startup result.

GitOrigin-RevId: e7fd63cf8690bcca8b5155266416f31f2f792aa2
@copyberry
copyberry Bot force-pushed the copyberry/codex-internal-to-codex-oss/e7fd63cf8690bcca8b5155266416f31f2f792aa2 branch from 25b6a31 to b7f7102 Compare September 3, 2026 01:27
@copyberry
copyberry Bot merged commit b7f7102 into main Sep 3, 2026
26 of 32 checks passed
@copyberry
copyberry Bot deleted the copyberry/codex-internal-to-codex-oss/e7fd63cf8690bcca8b5155266416f31f2f792aa2 branch September 3, 2026 01:28
@github-actions github-actions Bot locked and limited conversation to collaborators Sep 3, 2026
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant